Il blog di Giuseppe Marchi - SharePoint MVP
NAVIGATION - SEARCH

Errore “This product requires Microsoft .Net Framework 4.5”

Provando ad fare una nuova installazione di SharePoint Server 2013, su una macchina Windows Server 2012 R2, sono incappato in questo errore:

Setup is unable to proceed due to the following error(s): This product requires Microsoft .Net Framework 4.5


Eppure avevo una macchina aggiornata con le ultime patch, l'installazione dei pre-requisiti era stata eseguita senza errori e dall'elenco delle Features di Windows vedevo correttamente il .NET Framework 4.5 abilitato.
Mi affido a Google e trovo questa KB: https://support.microsoft.com/it-it/kb/3087184
L'articolo spiega esattamente il mio errore e mi dice che il problema è dato dal fatto che sulla macchina c'è installato o il .NET Framework 4.6 o il 4.6.1 e l'installer di SharePoint Server 2013 non riconosce nessuna di queste due versioni.
Le soluzioni date dall'articolo della KB sono:
  • Disinstalla il .NET Framework 4.6 o 4.6.1 da Programs and Features (sconsigliatissimo)
  • Utilizza l'utility ".NET Framework Cleanup Tool" ed elimina le versioni superiori alla 4.5
Peccato che nel mio caso nessuna delle due soluzioni era quella corretta.
Su una macchina Windows Server 2012 R2, aggiornata con gli ultimi update di Microsoft (a oggi), il .NET Framework 4.6 viene installato da un singolo update (KB3102467) e quindi non è presente all'interno di Programs and Features. In aggiunta, l'utility ".NET Framework Cleanup Tool" non ha avuto la minima intenzione di fare il suo lavoro.
La soluzione al problema è stata quella di disinstallare a mano l'update 3102467 dall'elenco degli aggiornamenti fatti sulla macchina.

blog comments powered by Disqus